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 1 Paquets de software amb aplicacions ofimàtiques

En 1990, l'empresa Microsoft (MS) va llançar al mercat el programari anomenat 

Office 1, un paquet que contenia les aplicacions Word (processador de textos), Excel 

(full de càlcul) i PowerPoint (aplicació per fer presentacions). Aquest paquet MS 

Office només funcionava amb el sistema operatiu MS Windows, que en aquells temps

era el predominant. 

Cada 2 o 3 anys varen sortir noves versions de MS Office al mercat i es va afegir la 

base de dades Access.

Com el paquet MS Office costa al voltant de 100 euros, diverses organitzacions de 

programadors varen desenvolupar paquets ofimàtics amb aplicacions similars a les de

MS Office, amb la diferència que aquests paquets ofimàtics són gratuïts i alguns 

d'ells de codi obert.  

S'anomena programa propietari a software que s'ha de comprar i la redistribució del 

qual no és lliure. 

Molt del software lliure i gratuït també és de codi obert. Això permet accedir al codi 

font del software i modificar les seves funcions.

http://computerhoy.com/listas/software/7-mejores-alternativas-gratis-microsoft-

office-11361
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 1.1 LiberOffice

LiberOffice és un paquet ofimàtic que conté les aplicacions

• Writer

Processador de textos

• Impress

Presentacions

• Calc

Full de càlcul

• Base

Base de dades

• Draw

Dibuix tècnic

• Math

Editor de fórmules matemàtiques

LiberOffice es pot descarregar gratuïtament des de www.libreoffice.org.
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 1.1.1 Presentacions amb Impress

Impress és una aplicació per realitzar presentacions amb forma d'una seqüència 

d'imatges, similar a una presentació amb diapositives.

Una presentació tracta de presentar de forma esquemàtica continguts, p. ex. idees 

principals d'un article.

En una presentació es poden incloure imatges que complementin els textos, per 

millorar la comprensibilitat del contingut, p. ex. imatges d'un transportador d'angles 

en les instruccions d'utilització d'aquesta eina (mostrar exercici7.odp ).

Com és habitual en els documents multimèdia, una presentació pot disposar 

d'hiperenllaços per accedir a planes web.

Es pot triar entre diverses formes de transició entre diapositives.

Les interaccions entre elements de diapositives s'activen en clicar damunt un 

element de la diapositiva. Aquesta acció pot causar saltar a una altra diapositiva, 

activar un arxiu d'àudio o un macro.

L'animació d'un element significa que en clicar damunt la diapositiva, l'element 

animat apareix en forma d'un moviment. Impress ofereix una amplia gama de 

animacions per determinar el moviment de l'element (veure presentació 

impress_mostra_1).
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Hiperenllaços, transicions, interaccions i animacions poden ajudar a entendre millor 

els continguts i a amenitzar la presentació, però, mal utilitzats, poden provocar la 

distracció del públic. S'han d'utilitzar amb seny.    

Les presentacions dels exercicis següents han de tenir com a màxim 10 diapositives.

Cada presentació ha de dur una portada amb títol i noms dels autors. 
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 1.1.1.1 Exercicis Impress

Exercici 1.1.1.1-1

Fes una presentació Impress en la que s'explica com crear un nou document.

Exercici 1.1.1.1-2

Fes una presentació Impress en la que s'expliquen els components de la finestra 

principal.

Exercici 1.1.1.1-3

Fes una presentació Impress en la que s'explica com formatar text.

Exercici 1.1.1.1-4

Fes una presentació Impress en la que s'explica com fer un hiperenllaç.

Exercici 1.1.1.1-5

Fes una presentació Impress en la que s'explica com fer la transició de diapositives.

Exercici 1.1.1.1-6

Fes una presentació Impress en la que s'explica com aplicar una animació a un 

element.

Exercici 1.1.1.1-7

Fes una presentació Impress en la que s'explica com aplicar una interacció a un 

element.

Exercici 1.1.1.1-8

Cerca tutorials d'Impress en català i castellà a internet i fes una presentació dels 

tutorials trobats. 
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 1.1.1.2 Activitat 1

Presentació relacionada amb un dels següent temes 

• Música 

• Escriptura 

• TIC

• Cinematografia

• Esport

Estructura de l’activitat: 

Portada (Diapositiva 1) 

Index: (Diapositiva 2)

La presentació ha de tractar un dels següents temes

 No menys de 5 ni més de 15 diapositives

Webgrafia (Diapositiva final) 

Recursos que s'han d'utilitzar en la presentació: 

• Animació personalitzada dels elements 

• Transició de les diapositives 

• Interaccions 

• Hiperenllaços 

La data d’entrega serà el dilluns 28/09/2010
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 1.1.1.3 Documentació Impress

Tutorial Impress en anglès.

Tutorial Impress en castellà.
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 1.1.2 Processador de text Writer

Un processador de text permet escriure un document de text i formatar el text perquè 

tingui la aparença desitjada.

 1.1.2.1 Recursos de Writer

• Obrir i desar un document

File > Open > cercar arxiu en Places > clicar damunt el nom de l'arxiu que es 

vol obrir.

Exemple

• Configurar una pàgina

Format > Page > tab 2, Page > s'obre una finestra que permet seleccionar 

mida del paper, orientació de la pàgina, marges i layout.

Exemple

Formatant text

• Introducció de text

S'introdueix text amb el teclat.

Exemple

• Seleccionar i esborrar text

Situar el cursor a l'inici del text que es vol esborrar. Seleccionar el text a 

esborrar prement la tecla majúscula i movent el cursor al  llarg del text a 

esborrar. Una vegada seleccionat el text, prémer la tecla suprimir (Supr).

Exemple 
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• Copiar i enganxar

Seleccionar text > copiar amb Ctrl + c > enganxar amb Ctrl + v.

• Cercar i reemplaçar text

Edit > Find & Replace > inserir text a cercar en Search for >  inserir nou text

en Replace with > clicar damunt Find i Replace.

Exemple

• Desfer i fer

Edit > Undo per desfer el darrer canvi del document.

Ctrl + z

Edit > Redo anul·la l'efecte de Undo, és a dir, trona a fer el darrer canvi del 

document.

Exemple

• Font i mida de lletra

Seleccionar el text a formatar > Format > Character > tab 1, Font >triar font 

en Family, estil en Style i mida en Size.

Exemple

• Efectes especials
Seleccionar el text a formatar > Format > Character > tab 2, Font Effects > 

seleccionar els efectes desitjats.

Exemple 1
Exemple 2
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• Format predeterminat

Format > per eliminar tota la formatació del text realitzada Clear direct 

formating.

Exemple

Formatant Paràgrafs

• Sagnats, espai entre paràgrafs i línies
Format > Paragraph > tab 1, Indents & Spacing > seleccionar sagnats

i espais.
Exemple

• Vores i ombrejats

Seleccionar paràgraf > Format > Paragraph > tab 7, Borders > seleccionar 

vores

Exemple

• Imatge de fons

Format > Paragraph > Background >  triar Graphic en As > seleccionar imatge

a inserir en File clicant sobre Browse.

Exemple

• Tabuladors

Seleccionar paràgrafs > Format  > Paragraph > tab 5, Tabs.

Exemple 1

Exemple 2
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• Format en paràgrafs consecutius

Edit > Repeat.

E  xemple

➢ Esquema numerat

Format > Bullets and Numbering. 

Exemple

Imatges i formes

• Ancoratge i alineació d'una imatge

Clicar amb el botó dret damunt la imatge per accedir al menú Anchor > 

seleccionar el tipus d'ancoratge en les opcions que apareixen.

Alinear la imatge > View > Toolbars > Aling Objects 

Exemple

• Mida i retall d'una imatge

Format > Image > tab 6,  Crop > opcions Crop, Scale, Image Size

Exemple

• Galeria d'imatges

Tools > Gallery > slecciona imatges dels temes o crea un nou tema amb les 

teves imatges.

Exemple
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• Inserir objectes de dibuix

View > Toolbars > Drawing > apareix la part inferior de la finestra principal 

una barra amb eines de dibuix que permet crear objectes.

• Inserir text animat en un objecte de dibuix

Seleccionar l'objecte > Fer doble clic damunt l'objecte per poder introduir text 

> Fer clic amb botó dret  damunt el  text i seleccionar Text del menú > 

Seleccionar l'etiqueta Text animation > Triar efectes.

Exemple

•

Per activar Fontwork > View > Toolbars > Fontwork > Apareix la barra 

d'eines Fontwork a la part inferior de la pantalla.

Exemple

Taules

• Inserir una taula

Table > Insert > Table > Seleccionar les característiques de la taula.

Exemple

• Seleccionar una taula

Table > Select > Table.
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• Seleccionar, copiar, esborrar

Seleccionar, copiar i esborrar elements d'una taula.

Exemple

• Inserir files i columnes

Seleccionar taula > Table > Insert > Rows o Columns > Determinar nombre i 

posició.

Exemple

• Modificar mides de taula, columnes i files

Seleccionar la taula > Table > Table Properties > Width > Ajustar l'ample 

total de la taula.

Seleccionar la taula > Table > Table Properties > tab 3, Columns > 

Seleccionar l'ample de les columnes (la suma de l'ample de les columnes ha de 

donar l'ample de la taula).

Seleccionar fila de la taula > Clic amb botó dret > Row > Height.

Exemple
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• Fons i vores

Seleccionar taula > Table > Table Properties > tab 4, Borders o tab 5, 

Background.

Exemple

• Texto Taula

Table > Convert.

Exemple

• Unir i dividir cel·les

Seleccionar cel·les a unir > Table > Merge Cells.

Seleccionar cel·la a dividir > Table > Split Cells....

Exemple

• Crear  i aplicar format taula

Seleccionar taula amb el format que es vol crear > Table > Autoformat > Add

> Donar nom al format.

Seleccionar la taula a la qual es vol aplicar format >  Table > Autoformat > 

Seleccionar el format desitjat de la llista > Ok. 

Exemple
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• Ordenar elements d'una taula

Seleccionar taula > Tools > Sort. 

Exemple

A D

B A

B C

C B

C E

• Fórmules

Seleccionar cel·la en la qual es vol inserir una fòrmula > Table > Formula > 

 > Seleccionar la fórmula del desplegable > Inserir un argument a la 

fórmula seleccionant una cel·la > Confirmar clicant damunt .

X en graus X en radians (3,14 = 180º) Sin(x)

0º 0,00 0,00

15º 0,26 0,26

30º 0,52 0,50

45º 0,78 0,70

90º 1,57 1,00

180º 3,14 0,00
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Altres eines

• Salt de pàgina

Col·locar el cursor en la posició en la qual es vol inserir el salt de pàgina > 

Insert > Manual Break... > Page break > OK

Exemple

• Crear seccions

Seleccionar un o més paràgrafs > Insert > Section... > Anomenar 

i configurar la secció seleccionada > Insert.

Per començar un nou paràgraf fora de una secció, pulsar Alt + Intro.

 

• Configurar seccions

Col·locar el cursor en la secció que es vol modificar >

Format > Sections > Options > configurar i 

desar.

Exemple

• Vista prèvia

Exemple

• Estils (Heading 1)
Els estils s'apliquen a paràgrafs, caràcters, marcs, pàgines o llistes.

Format > Styles and Formatting

Exemple1

Exemple 2
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 1.1.2.2 Exercicis Writer

Exercici 1.1.2.2-1
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Exercici 1.1.2.2-2
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Exercici 1.1.2.2-3

Crea un document Writer amb la següent configuració de pàgina.

• Format A3.

• Marges 

◦ Superior i inferior 3 cm

◦ Esquerre i dret 1,5 cm

• Orientació apaïsat

Desa el document com a «el_teu_nom_1.1.6.3»

Exercici 1.1.2.2-4

Crea la taula següent en el document «el_teu_nom_1.1.6.3».

• Mida lletra 10.

• Tipus lletra Arial.

• Amplària taula 10 cm.

• Alçada taula 5 cm. 

• Taula centrada a pàgina.
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Exercici 1.1.2.2-5

Insereix el següent encapçalat en el document «el_teu_nom_1.1.6.3».

• Font Verdana

• Mida 12

• Color verd

• Centrat

TELÈFON D'ATENCIÓ 967 665 588

Exercici 1.1.2.2-6

Insereix el següent peu de pàgina en el document «el_teu_nom_1.1.6.3».

• Font Verdana

• Mida 10

• Alineat a la dreta.

Pàgina x de y

On x és el nombre de pàgina i y és el total de pàgines.

Exercici 1.1.2.2-7

Insereix la data, que ha d'actualitzar-se automàticament, en l'encapçalat del document 

«el_teu_nom_1.1.6.3».

• Font Verdana

• Mida 12

• Alineat a dreta
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Exercici 1.1.2.2-8

Afegeix una taula de continguts i un esquema numèric al següent text perquè quedi 

com es mostra a les pàgines 25, 26 i 27.

HISTORIA DE INTERNET

INTRODUCCIÓN

Algunos definen Internet como "La Red de Redes", y otros como "La Autopista de la Información".

Efectivamente, Internet es una Red de Redes porque está hecha a base de unir muchas redes locales 
de ordenadores, o sea de unos pocos ordenadores en un mismo edificio o empresa. Además, ésta es 
"La Red de Redes" porque es la más grande. Prácticamente todos los países del mundo tienen 
acceso a Internet. En algunos, como los del Tercer Mundo, sólo acceden los multimillonarios y en 
otros como USA o los países más desarrollados de Europa, no es difícil conectarse.

Por la Red Internet circulan constantemente cantidades increíbles de información. Por este motivo 
se le llama también La Autopista de la Información. Hay 50 millones de "Internautas", es decir, de 
personas que "navegan" por Internet en todo el Mundo. Se dice "navegar" porque es normal el ver 
información que proviene de muchas partes distintas del Mundo en una sola sesión. 

HISTORIA DE INTERNET

Internet nació en EE.UU. hace unos 30 años. Un proyec tomilitar llamado ARPANET pretendía 
poner en contacto una importante cantidad de ordenadores de las instalaciones del ejercito de 
EE.UU. Este proyecto gastó mucho dinero y recursos en construir la red de ordenadores más grande
en aquella época.

SERVICIOS DE INTERNET

Las posibilidades que ofrece Internet se denominan servicios. Cada servicio es una manera de 
sacarle provecho a la Red independiente de las demás. Una persona podría especializarse en el 
manejo de sólo uno de estos servicios sin necesidad de saber nada de los otros. Sin embargo, es 
conveniente conocer todo lo que puede ofrecer Internet, para poder trabajar con lo que más nos 
interese.

SERVICIO CORREO

El Correo Electrónico nos permite enviar cartas escritas con el ordenador a otras personas que 
tengan acceso a la Red. Las cartas quedan acumuladas en Internet hasta el momento en que se 
piden. Es entonces cuando son enviadas al ordenador del destinatario para que pueda leerlas. El 
correo electrónico es casi instantáneo, a diferencia del correo normal, y además muy barato. 
Podemos cartearnos con cualquier persona del Mundo que disponga de conexión a Internet.

SERVICIO FTP

El FTP (File Transfer Protocol) nos permite enviar ficheros de datos por Internet. Ya no es necesario
guardar la información en disquetes para usarla en otro ordenador. Con este servicio, muchas 
empresas informáticas han podido enviar sus productosa personas de todo el mundo sin necesidad 
de gastar dinero en miles de disquetes ni envíos. Muchos particulares hacen uso de este servicio 
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para, por ejemplo, dar a conocer sus creaciones informáticas a nivel mundial. 

EL SERVICIO IRC

El servicio IRC (Internet Relay Chat) nos permite entablar una conversación en tiempo real con una
o varias personas por medio de texto. Todo lo que escribimos en el teclado aparece en las pantallas 
de los que participan de la charla. También permite el envío de imágenes u otro tipo de ficheros 
mientras se dialoga.

ESTRUCTURA DE LA RED INTERNET

En los últimos años se han desarrollado grandes redes que unían ordenadores de empresas o de 
particulares. Estas redes, eran de tipo LAN o WAN. Internet es otra Red que está por encima de 
éstas y que las une a todas.

Tenemos como ejemplo los conocidos "Servicios On-Line" en EE.UU. Son redes de ordenadores a 
los que se podían conectar particulares con el fin de conseguir programas o contactar con otros 
usuarios por correo. A estas redes se subscribían los usuarios pagando una cuota. "America On-
Line", "Compuserver" ó "The MicrosoftNetwork" son algunas de éstas redes. Con la llegada de 
Internet, los usuarios de estas redes disponen de más alcance puesto que se les permite contactar 
con ordenadores que están fuera de su Red, o sea en Internet. 

DIRECCIONES IP Y NOMBRE DE DOMINIO

Cada ordenador que se conecta a Internet se identifica por medio de una dirección IP. Ésta se 
compone de 4 números comprendidos entre el 0 y el 255 ambos inclusive y separados por puntos. 
Así, por ejemplo, una dirección IP podría ser: 155.210.13.45. 

DIRECCION IP

Cada número de la dirección IP indica una sub-red de Internet. Hay 4 números en la dirección, lo 
que quiere decir que hay 4 niveles de profundidad en la distribución jerárquica de la Red Internet.

DISTRIBUCIÓN IP

Esta distribución jerárquica de la Red Internet, permite enviar y recibir rápidamente paquetes de 
información entre dos ordenadores conectados en cualquier parte del Mundo a Internet, y desde 
cualquier sub-red a la que pertenezcan.

CONEXIÓN A LA RED

Los ordenadores domésticos acceden a Internet a través de la línea telefónica. Podemos aprovechar 
la línea que casi todos tenemos en casa. Normalmente, esta línea telefónica tiene un conector en la 
pared, al que se suele enchufar el teléfono. Para poder enchufar nuestro ordenador a este conector 
debemos disponer de un módem, que viene con un cable de teléfono. Este aparato sirve para que el 
ordenador pueda comunicarse a través del teléfono con otros ordenadores. 

Con el fin de evitar enchufar y desenchufar el módem y el teléfono cada vez que conectamos con 
Internet, casi todos los módems tienen dos conectores: "Phone" y "Line-In". Tenemos que conectar 
el cable que viene con el módem al conector "Line-In" (entrada de la línea), y por el otro extremo, 
lo conectamos a la clavija de la línea telefónica, o sea, donde antes teníamos enchufado el teléfono. 
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 1.1.2.3 Activitat 2

Redacta un article fet amb Writer amb el tema 

«La societat de la informació i l'ordinador»

Nombre màxim de paraules 1500.

Aspectes a considerar

• Evolució històrica de la informàtica

• La societat de la informació

• Web 2.0

• Noves professions derivades de l'ús dels ordinadors

Data d'entrega, dilluns 05/10/15.
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 1.1.2.4 Documentació Writer i enllaços d'interès

Tutorial Writer en castellà.

Tutorial Writer en anglès.

http://www.pitt.edu/~poole/libreofficeframe.htm

http://ticenelbachilleratodeadultos.blogspot.com.es/p/writer-como-se-hace.html
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 1.1.3 Full de càlcul Calc

Calc és el full de càlcul de LibreOffice.org (LibreOffice). Un full de càlcul permet 

inserir dades per organitzar-les, fer càlculs o crear gràfics.

 1.1.3.1 Recursos de Calc

• Seleccionar conjunts de dades separats

Seleccionar el primer conjunt de dades > Mantenir Ctrl pitjada i seleccionar el 

següent conjunt de dades.

• Càlcul aritmètic (+, -, *, /)

Seleccionar la cel·la en la qual es vol inserir la operació > Inserir  = > Inserir 

l'identificador de cel·la del primer argument >  Inserir  l'operador (+, -, *, /) > 

Inserir els identificadors de cel·la dels següents arguments, seguits d'operadors 

> Pitjar tecla Intro. 

• Inserir funció matemàtica

Seleccionar la cel·la en la qual es vol inserir la funció > Insert > Function > 

Seleccionar la categoria de la funció > Mathematical > Clicar dues vegades 

damunt la funció seleccionada i seleccionar arguments.

• Inserir gràfics

Insert > Object > Chart > Chart Wizard
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L'ajuda de LiberOffice disposa de llistats amb explicacions i exemples de cada una de

les funcions.

• Funcions de Calc

https://help.libreoffice.org/3.6/Calc/Functions_by_Category/es
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• Funcions matemàtiques de Calc

https://help.libreoffice.org/3.6/Calc/Mathematical_Functions/es
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Diferència entre les funcions MITJANA (MEDIANA, MEDIAN) i SUBTOTAL

La funció SUBTOTAL pertany al grup de funcions matemàtiques i, amb el paràmetre 

1, calcula la mitjana aritmètica d'un conjunt de nombres.

Exemple, del conjunt 1, 2, 2, 3, 4, 5, torna el nombre 2,83, que és la suma dels 

nombres del conjunt, dividida entre el nombre de nombres del conjunt.

La funció MITJANA pertany al grup de funcions estadístiques. No precisa 

paràmetres. Torna el nombre mitjà d'un conjunt de nombres. 

Exemple, del conjunt 1, 2, 2, 3, 4, 5, torna el nombre 3, que és el que es troba a la 

mateixa distància del nombre més baix i més alt del conjunt. 

Funció SI
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Funció COMPTASI (COUNTIF)

Aquesta funció pertany al grup de les funcions estadístiques.
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Mathematical function SUBTOTAL
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Funció LOOKUP (CONSULTA, BUSCAR)
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 1.1.3.2 Exercicis Calc

Exercici 1.1.3.2-1

Crea un document Calc amb la següent taula i insereix les funcions necessàries per 

fer els càlculs que s'indiquen en la taula.

Solució 1

Solució 2
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Exercici 1.1.3.2-2

Crea un document Calc amb la següent taula i insereix les funcions necessàries per 

fer els càlculs que s'indiquen en la taula.

Solució
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Exercici 1.1.3.2-3

Crea els gràfics basats en les taules del document.

Solució 1

Solució 2
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Exercici 1.1.3.2-4

Completa les sèries.

Solució
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Exercici 1.1.3.2-5

Crea el següent document.

Solució 1

Solució 2

Solució 3
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Exercici 1.1.3.2-6

Crea el següent document.

Solució
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Exercici 1.1.3.2-7

Solució 1, solució 2

Exercici 1.1.3.2-8

Solució

Exercici 1.1.3.2-9

Solució

Exercici 1.1.3.2-10

Solució 1, solució 2, solució 3
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 1.1.3.3 Activitat 3

3.1

Crea un document Calc en el que es calculi el valor absolut dels  nombres sencers 

entre -20 i 20. 

3.2

Completa el full de càlcul comandes.

Aquesta activitat tracta la gestió d'un magatzem d'un bar. 

Un empleat arriba al bar a les 7 del matí, abans que el bar obri, i utilitza el full de 

càlcul per fer la comanda amb la informació de la columna J. La comanda li arriba el 

mateix dia a la tarda, quan ja s'han fet les consumicions diàries (columna F). Al 

capvespre, en tancar el bar, s'actualitzen les existències (columna E).

La condició per fer comanda és que les existències baixin sota el stock mínim 

(columna G), tenint en compte el consum al llarg del dia.  El stock màxim (columna 

H) mai sa de superar, ja que el magatzem no disposa d'espai físic per més begudes.

Preguntes

Quines funcions utilitzaries per resoldre aquesta activitat?

Quina és la condició necessària per reposar articles?

En cas que un article s'hagi de reposar, com es calcula la quantitat a reposar?

Les consumicions diàries indiquen el consum diari estimat. Què passa amb el stock si

un dia no hi ha consum? I què passa si un dia es consumeix tot el stock d'un article?
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Simulació de funcionament del full de càlcul comandes

Per a cada una de les begudes, simula 18 dies d'activitat del bar amb el consum diari 

estimat, 1 dia amb consum 0, seguit de 3 dies amb consum diari estimat  i 1 dia amb 

consum total de les existències, seguit de 3 dies amb consum diari estimat. Completa 

la següent taula.

Beguda X

Stock mínim = Y

Dia Existències
7:00 hores

Reposar
condició → 
reposar

Consum diari Comanda
si reposar “sí” 
→ operació

Existències 
22:00 hores

1 estimat

2 estimat

3 estimat

4 estimat

5 estimat

6 estimat

7 estimat

8 estimat

9 estimat

10 estimat

11 0

12 estimat

13 estimat

14 estimat

15 existències

16 estimat

17 estimat

18 estimat
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S'han d'entregar 3 documents

• Full de càlcul solucionat

• Document de text amb resposta a les qüestions plantejades en aquest enunciat.

• Un document de text amb les simulacions. 

Data d'entrega,  dilluns 09/11/15.
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 1.1.3.4 Activitat 4

Entrega del exercicis 1.1.3.2-1 a 1.1.3.2-10.

Data d'entrega,  divendres 11/12/15 

L'activitat s'ha d'enviar per correu electrònic a pposada@iessonpacs.cat

 1.1.3.5 Documentació Calc i enllaços d'interès

Tutorial Calc en castellà.
Tutorial Calc en anglès.
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 1.1.4 Base de dades Base

Una base de dades està formada per un conjunt de taules amb dades. Les dades de les 

taules es poden relacionar entre elles, com es fa per exemple en una entitat bancària, 

que relaciona dades personals dels clients amb dades econòmiques, en un hospital, on

es treballa amb dades mèdiques o en una biblioteca, on es relaciona un fons de llibres 

amb els usuaris i els préstecs.

• Un processador de textos organitza les dades, principalment textos, en 

paràgrafs i frases.

• Un full de càlcul organitza les dades, principalment nombres, en files i 

columnes.

• Una base de dades organitza tota mena de dades en registres i camps.

 1.1.4.1 Crear una base de dades nova

La base de dades nova es pot crear obrint Base des del menú de programes,

o, si hi ha una aplicació de LiberOffice oberta, amb

FILE > NEW > DATABASE
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A continuació s'inicia l'assistent per crear una nova base de dades i apareix la següent 

finestra.

Seleccionem crear nova base de dades > NEXT.

Paulino Posada Blog pàg. 51 de 124 

2

1

http://tic-tac-2015.blogspot.com.es/


TIC  09/18

En aquesta finestra deixem les seleccions per defecte. La primera fa referència al 

registre de la base de dades. El registre és necessari perquè altres aplicacions de 

LiberOffice hi puguin accedir.

La segona obre la base de dades per editar-la. 
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 1.1.4.2 Què és una taula

Una taula és una mena de formulari o model, on es recullen dades, p.ex d'assumptes 

pendents i resolts, com mostra la següent imatge. La taula determina l'estructura de 

les dades recollides.

És necessari que una taula disposi d'un camp identificat com a clau principal (key). 

Aquest camp serveix per numerar totes les entrades de la taula de forma automàtica. 

Cada vegada que es crea una nova entrada a la taula, el nombre del camp «clau 

principal», augmenta el seu valor en 1. En la imatge, la clau principal és el camp ID. 

La clau principal serveix com a nombre de referència per a cada una de les entrades 

(registres) d'una taula i és necessari per relacionar diverses taules. 
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 1.1.4.3 Crear una taula

Hi ha dues opcions per crear taules noves. La primera en vista disseny (Create Table 

in Design View) permet definir la taula segons les nostres necessitats. L'altra, amb 

l'assistent deixa triar entre uns models de taules predefinits.

En el primer exemple crearem una taula en vista disseny. 
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Ara hem de definir els camps de la nostra taula i les seves propietats. La nostra 

primera taula la crearem per utilitzar-la com a agenda, així doncs, necessitarem 

camps com nom, cognom, adreça, etc.

Per no només hem de definir els camps, sinó també les propietats dels camps, és a 

dir, si les dades que introduirem en un camp són numèriques, text, o si el camp és 

clau principal de la taula. Normalment, el primer camp serà la clau principal de la 

taula. El seu valor és numèric, del tipus INTEGER (nombre sencer) i ha de créixer de

forma automàtica a mesura que afegim camps a la taula.

Per a la resta de camps, es pot deixar el valor predeterminat Text VARCHAR, que 

indica que el format de les dades serà de text.
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A la finestra principal de la base de dades ara apareix la nova taula adreces en la 

secció de taules.
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 1.1.4.4 Introduir dades a una taula

Clicant damunt adreces, s'obre la taula per introduir-hi dades.

Introduïdes les dades, la taula es desa FILE > CLOSE.

Al peu de la finestra es troba informació referent al registre actiu, nombre de registres

de la taula i uns botons que permeten moure's entre els registres.
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 1.1.4.5 Fer una còpia d'una taula

En primer lloc, canviarem el nom de la taula adreces a adreces_1:

seleccionar taula adreces > pitjar botó dret > Rename > indicar nou nom > ok 

Per fer una còpia la taula adreces_1, seleccionem la taula, pitgem el botó dret del 

ratolí i seleccionem copiar. A continuació enganxem a la mateixa secció Tables.

En la finestra Copy table, deixem l'opció que surt per defecte, Definition and data, 

ja que volem copiar la taula amb tots els seus registres. Si triéssim Definition, 

copiaríem la taula sense els registres i obtindríem una taula buida. 
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A la finestra Apply columns podem triar quins camps volem copiar a la nova taula. 

Com volem copiar tots, pitjem

A la finestra Type formatting podem deixar tot com està, ja que no volem fer canvis 

en el format dels camps.Treminem pitjant Create.

Ara apareix la taula adreces_2 a la secció Tables.
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 1.1.4.6 Afegir un camp a una taula

Volem afegir a la taula adreces_1 un camp per desar la data de la creació del registre. 

El format de la data ha de ser DD/MM/YY.

Cliquem amb el botó dret damunt la taula adreces i seleccionem editar. 

Desem la taula i en tornar a obrir-la, veurem que el camp Data està present.
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 1.1.4.7 Afegir un camp amb entrada obligatòria

Ara volem afegir a la taula adreces_2 un camp per desar la data de la creació del 

registre. A més, l'entrada de la data de creació del registre, ha de ser obligatòria i amb 

el format DD/MM/YY.

Com la taula adreces_2 ja conté entrades, no li podem afegir un camp amb entrada 

obligatòria, ja que per a les entrades existents, aquest camp no tindria entrada.

Per això, hem de fer una còpia dels registres d'adreces_2 a un document Calc, on 

podrem afegir dates als registres.

Els registres copiats els enganxem en el document Calc.

Ara afegim data a cada un dels registres.

Seleccionem el rang A1 a H7, el copiem i enganxem a la secció de taules d'Acces.
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Apareix la finestra copy table, en la que hem de activar la creació de clau principal 

(Create primary key).

El nom de la nova taula serà Table1.
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Ara seleccionem tots els camps perquè siguin creats a Table1.

A la finestra Type formatting, hem de canviar el tipus de dades del camp Data a Date 

en Field type i activar YES en entrada requerida (Entry required).
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En l'apartat de taules apareixen les taules adreces_1, adreces_2 i Table1.

Podem esborrar adreces_2, ja que és idèntica a adreces_1 i canviar el nom de Table 1 

a adreces_2,  clicant damunt Table 1 amb el botó dret i selecciona Rename.
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Exercici 1.1.4.5-1

Crea una base de dades anomenada «el_teu_nom_test_1».

Crea una taula anomenada «biblioteca», amb els camps ID, títol, autor, comentari, 

data.

Les característiques dels camps de la taula «biblioteca» són les següents:

Nom del camp Tipus del 
camp

Entrada 
necessària

Valor 
defecte

Longitud Exemple de 
format

ID INTEGER sí

Títol text sí 50

Autor text sí 30

Data d'edició data sí 31/12/1999

Comentari memo

Data de registre data sí 31/12/99

Preu decimal sí 0 5 estàndard

Crea una altra taula anomenada «economia», amb els camps concepte, import, data. 

Nom del camp Tipus del 
camp

Entrada 
necessària

Valor 
defecte

Longitud Exemple de 
format

ID INTEGER sí

Concepte text sí 20

Import decimal sí 0 5 estàndard

Data de registre data sí 31/12/99

Introdueix 5 registres en cadascuna de les taules.
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 1.1.4.8 Formularis

Un formulari mostra la informació d'un registre d'una taula. Podem dissenyar el 

formulari, perquè ens mostri la informació del registre de la forma que ens 

convengui. Per exemple, un formulari pot mostrar només alguns dels camps del 

registre, per facilitar la lectura de les dades. A més, els formularis també serveixen 

per introduir  nous registres a la taula.

La imatge mostra com a exemple un formulari creat per a la taula adreces.
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 1.1.4.9 Creació de formularis amb l'assistent

Per crear aquest formulari, seleccionem Forms (Formularis) en la secció Database 

(Bases de dades) de la finestra principal. Crearem el formulari amb l'assistent per a 

creació de formularis.

Ara es seleccionen els camps que volem que apareguin al formulari. En l'exemple són

nom, cognom i comentari.

Els camps disponibles es mostren en la secció esquerra i, pitjant la fletxa (2), passen a

la secció de Camps en formulari de la dreta.
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Ara apareix una finestra que demana si volem inserir subformularis, cosa que no 

volem fer.

Pitgem següent i apareix una finestra que permet organitzar els controls del  

formulari. Els controls són els espais on apareixeran, o ficarem, les dades 

corresponents als camps que hem seleccionat abans.

Es pot seleccionar entre diversos dissenys del formulari. Seleccionarem el de 

l'esquerra.

L'etiqueta (lable) d'un control és un text que apareix proper al control i l'identifica.

Per a la posició de les etiquetes, deixarem l'opció per defecte.
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La següent finestra serveix per configurar l'entrada de dades. La primera opció 

permet configurar-la per introduir dades noves, sense mostrar les existents. 

Deixarem activada l'opció per defecte, mostrar totes les dades, sense triar cap de les 

subopcions.
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La següent finestra permet triar característiques d'estil del formulari, com el color de 

fons o els tipus de vores dels controls.

 Finalment hem de triar un nom per al formulari i ja el tenim com apareix a la pàgina 

65.
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Exercici 1.1.4.7-1

Per a les taules biblioteca i economia (exercici 1.1.4.5-1) crea els formularis biblio_1 

i eco_1 utilitzant l'assistent per a creació de formularis.

Controls 
biblio_1

Estil formulari Controls 
biblio_2

Estil formulari

Títol Alineament en 
columnes amb 
etiquetes a 
l'esquerra.
Fons formulari 
beige.
Vora controls 3-D.

Concepte Alineament en columnes, 
etiquetes damunt controls. 
Fons formulari violeta. 
Controls sense vora.

Autor Import

Data d'edició Data

Comentari

Data de registre

Preu
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 1.1.4.10 Creació de formularis en vista disseny

Volem crear un formulari per a la taula biblioteca, que anomenarem biblio. 

Seleccionem Crear formulari en vista disseny.
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Des de la barra d'eines Controls de formulari, podem inserir en el formulari quadres 

de text o camps formatats i etiquetar-los amb noms.

En  primer lloc hem de determinar les propietats del formulari. Per això ha d'existir 

com a mínim una etiqueta, quadre de text o camp formatat al formulari.
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En Tipus de contingut, indiquem que el formulari agafa les dades d'una taula. Al 

apartat de Contingut especifiquem la taula biblioteca, com l'origen de les dades del 

formulari.

Continuem amb el camp Títol de la taula biblioteca. Volem que la informació d'aquest

camp aparegui a la part superior esquerra del formulari bilio. Llavors, podem inserir 

un quadre de text, ja que el tipus de dades del camp Títol és text. 

També inserirem una etiqueta, que és el nom que aparexeirà identificant el quadre de 

text al formulari.

Una vegada inserits etiqueta  i quadre de text, hem de definir les seves propietats. Per 

això pitjarem el botó Selecció de propietats (3).
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Comencem per definir les propietats de l'etiqueta. La paraula que ha d'apareixer en 

l'etiqueta és Títol (1) i a més formatarem la lletra a Arial, mida 14, color rosa.
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Podem comprovar el resultat en el formulari, desactivant el modo disseny.

Passem definir les propietats del quadre de text.
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Igual que en l'etiqueta es pot formatar la lletra, que en aquest cas serà de tipus Arial, 

mida 14 i color verd.

La imatge mostra el formulari amb la informació del primer registre de la taula.

 

Afegirem ara al formulari un control amb la informació del camp Data.

Haurem de crear una etiqueta amb el text Data d'edició. Utlitzarem el mateix format 

que per l'etiqueta títol.
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Com el camp Data no és de tipus text, sinó de tipus data, inserirem un camp formatat,

amb format data, en lloc d'un quadre de text.
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En l'etiqueta Dades determinem l'origen de les dades del control com a Data d'edició.

El resultat és el següent.

Exercici 1.1.4.10-1

Fromata el text del control Data d'edició a Arial, mida 14, color verd.
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Terminarem aquest exemple inserint un camp formatat, amb dades provinents del 

camp preu de la taula biblioteca.

Primer inserim l'etiqueta amb el títol preu.

A continuació inserim un camp formtat. Triem com a format moneda.
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En l'apartat de dades, indiquem que l'origen de les dades del cotrol és el camp Preu.

El formulari resultant, hauria de ser similar al de la següent imatge.
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Exercici 1.1.4.10-2

Per a les taules biblioteca i economia, creades en l'exercici 1.1.4.5-1, crea formularis 

biblio_2 i eco_2, amb els següents controls i disseny:

Nom del control Nom del control

Títol del llibre Concepte

Autor Import en euros

Data d'edició Data registre

Comentari

Data de registre

PVP en euros
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Es pot esborrar  fàcilment el registre d'una taula des d'un formulari, pitjant la icona 

Abans d'efectuar-se l'eliminació del registre, quedem avisats que no podrem tornar 

enrere aquesta acció, i demana que confirmem l'eliminació
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 1.1.4.11 Recerques en taules i formularis

La recerca d'informació es una de les principals activitats que es realitzen amb una 

base de dades.

Per començar, descarrega la base de dades  Birds que conté la informació 

enregistrada per un aficionat a observar ocells.

Obrim el formulari birds  i veiem que el formulari mostra el primer registre d'un total 

de 51.

Volem cercar l'ocell song sparrow. Per això utilizarem la icona de recerca
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S'obre la finestra de recerca, en la qual haurem d'introduir el text a cercar.

Com es veu, hi ha tota una sèrie d'opcions per configurar la recerca, però per la 

majoria dels casos, la configuració per defecte és adient.

Pitjem cercar i el formulari mostrarà el registre cercat.
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A continuació volem fer una recerca amb un criteri que doni multiples resultats, per 

exemple, trobar tots els ocells el color1 dels qual sigui negre (black).

Per aixó, tanquem el formulari i obrim la taula Birds.

En el camp color 1, seleccionem qualsevol registre on posi black i cliquem damunt la 

paraula black perquè quedi ressaltada.

Ara utilitzem el recurs autofilter per mostrar només els registres on color 1 és 

black.

Per tonar a mostrar la taula completas¡elimina l'autofliter pitjant
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El filtre estàndard s'utilitza per receques amb més d'un criteri de recerca.

Per exemple, si volem mostrar els registres amb els ocells de color black al camp 

color 1 o brown al camp color 2 (black or brown), haurem de utilitzar el filtre 

estàndard de la següent manera. Atenció, s'ha de seleccionar l'opció OR.

     

Obtindrem el següent resultat.
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Un altre exemple és cercar els ocells negres i grans (black and large). Tornem a 

utilitzar el filtre standard, aquesta vegana seleccionant l'opció AND.

Només es mostren els registres que compleixen ambdues condicions, els ocells 

mostrats són negres i grans.
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Organització de la informació d'una taula

Les dades desades en una taula es poden ordenar de diverses maneres.

A la taula Birds, estan ordenades seguint la seqüencia del nombre identificador.

Amb els recursos per ordenar                    , podem ordenar-les fàcilment, per exemple,

per obtenir un ordre alfabetic al camp Common Name.

Amb el recurs ordenar descendent, obtendríem, l'order invers.
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Per ordenar utilitzant més d'un criteri, s'utilitza el recurs ordenar 

Per exemple, ordenarem la taula de forma que els camps color 1 i color 2 mostrin un 

ordre descendent.

Ara canviem l'ordre del color 2 a descendent.
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 1.1.4.12 Exemple de modificació de tipus de dades d'un camp

Volem ordenar els registres de la taula Birds per data descendent (primer el registre 

més recent, últim el més antic).

En intentar-ho, es presenta un problema, com es veu a la imatge, l'ordre per data no és

correcte.

Quin és el problema?

Mirem el format del camp data, editant la taula.
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El format del camp Date Sighted és Text, no Date, com hauria de ser per poder relizar

un ordenament per data.

Per poder ordenar els registres per data, hem de canviar el tipus de camp de 

Date Sighted a Date.

Si ho intentem, apareix el següent missantge d'error.

Perquè no es pot canviar el tipus de camp de Date Sighted a Date?

Misteri de la informàtica.

Farem una cosa per intentar resoldre aquest misteri.

Copiarem la taula Birds a un document Calc.

En primer lloc, seleccionarem tots els registres de la taula, després un  Ctrl+C 

(copiar), obrim un nou document de Calc i Ctrl+V (enganxar). 
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Resultat una vegada enganxat la taula en Calc.

Fixeu-vos en el format de la columna H, la data es mostra de dues maneres diferents, 

una en format DD/MM/YY (ex. 21/05/97), que és el format habitual, i una altra en 

DD-ABC-YY (ex. 15-Apr-96).

Un raig de llum il·lumina les nostres ments. Hem resolt el misteri. No podíem canviar

el tipus de camp de Text a Date, perquè Base no reconeix el format  DD-ABC-YY 

com a data i automàticament l'interpreta com a text.
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I com podem solucionar aquest problema?

Doncs, una data com per exemple 15-Apr-96, l'haurem de canviar a 15/04/96. Això 

ho farem amb Edit > Find&Replace.

Una vegada corregit el format de la data, copiem el rang de cel·les B2:K51 i 

l'enganxem en la secció de taules de la base de dades Birds, creant així una nova taula

que anomenarem Birds_date.

Es important que durant la creació de Birds-date, ens assegurem que el tipus de camp 

de Date Sighted és Date.
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Obrim ara la taula Birds_date i apliquem un ordre descendent utilitzant el camp Birds

Sighted i, voilà, tots els registres queden orenats per data com toca.

Som uns mags de primera.
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 1.1.4.13 Consultes i Informes

Un informe (report) és el que enviem al nostre cap, quan ell te a bé demanar-nos-en. 

A ningú l'interessa per a què el necessita. L'important és que ell el necessita i 

nosaltres l'hem de crear. Punt.

Per crear un informe, s'han de filtrar les dades de la base de dades i presentar-les 

adequadament. La creació d'informes no afecta el contingut de les taules de la base de

dades. Creant informes, no modifiquem en cap manera les dades enregistrades, 

simplement dissenyem una forma de filtrar i presentar-les.

Per crear un informe, primer hem de fer una consulta (query) sobre la informació 

d'una taula.

Per exemple, de la taula birds, volem informació respecte a tots els ànecs que hi 

surten.

Dels registres amb 'Duck' (ànec) en el camp Family, no ens interessen, peró, totes les 

dades, sinó únicament, les dades dels camps  Common Name, Family, Date Sighted

i Count. 

Així doncs, comencem a fer la consulta, seleccionant consulta a la finestra principal 

de la base de dades. 
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Per fer la consulta utilitzarem, per guiar-nos, l'assistent.

 

Ara seleccionem els camps que ens interessen perquè figurin a la consulta.
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A la següent finestra, podem triar un ordre pels registres de la consulta.

Els ordenem pel nom comú (Common Name), amb ordre descendent. 

A continuació, la finestra 3 permet selecionar els registres de la consulta en funció de 

les condicions i relacions lògiques que vulguem implementar. Aquí indicarem que 

volem seleccionar els registres amb els ocells de la família dels ànecs. 
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A la finestra 4, detall o resum, deixem la selecció per defecte, que mostra tots els 

registres de la selecció feta.

Saltem ara a la finestra 7, aliases, on podríem canviar els noms dels camps, si 

volguéssim, però no volem.

Finalment, a la finestra 8, es mostra una visió del conjunt de totes les selecciones que 

hem fet. 

  El resultat de la consulta el mostra la següent imatge.

Paulino Posada Blog pàg. 104 de 124 

http://tic-tac-2015.blogspot.com.es/


TIC  09/18

 1.1.4.13.1 Creació d'un informe basat en una consulta

Crearem un informe basat en la consulta Birds. A la finestra principal de la base de 

dades Birds.odb, seleccionem l'icona reports (informes). En l'apartat Tasks obrirem 

l'assistent per informes.
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La finestra 1, Field selection, permet seleccionar la taula de la qual l'informe agfa les 

dades. Pitjan la doble fletxa, tots els camps e la consulta passen a figurar en l'informe.
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La finestra 2, Labeling Fields, permet modificar els noms el camps, substituint-los 

per un nom d'etiqueta.

La finestra 3, Grouping, permet agrupar la informació. En aquest exemple, no 

agruparem.
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La finestra 4, Sort options, permet ordenar les dades. Triem Date Sighted, ascending, 

perquè siguin ordenades per data en ordre ascendent.

La finestra 5, Choose layout, permet triar un disseny per l'informe. En aquest 

exemple, deixarem el disseny per defecte.
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La finestra 6, Create report, permet anomenar l'informe. A més podem triar entre un 

informe estàtic o dinàmic. Estàtic vol dir, que l'informe no es modificarà, si les dades 

de la taula Birds canvien, mentre que, l'informe dinàmic sempre conté les dades de la 

taula actualitzada. 

Com no volem modificar el disseny de l'informe, triem Creat report now (crear 

informe ara).
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El resultat de la nostra consulta és el següent.

Si provem, veurem que l'informe no es pot modificar en Writer. Per canviar 

continguts de l'informe, l'hem  de tancar, tornar a la secció d'informes de la base de 

dades, clicar amb el botó dret del ratolí damunt l'informe que volem modificar i 

seleccionar editar.

Desar i tancar.
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Per veure l'informe modificat, el tornem a obrir des de la secció informes de la base 

de dades.
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 1.1.4.14 Exercicis Base

Exercici 1.1.4.14-1

a) Afegeix a la taula Birds table, de la base de dades Birds, el següents registres.

b) Ara fes una consulta, anomenada birds_count_2, basada en la taula Birds 

table,  en la qual seleccionis tots els ànecs (duck) i les merles (oriole).

Els camps de la taula que s'han d'incloure a la consulta són:

• Comon Name

• Family

• Date Sighted

• Count 

• Location Sighted

 L'ordre dels resultats de la consulta ha de ser per data descendent.

c) Fes un informe, en el qual s'agrupi per família i tria l'estil elegant.

L'iforme ha de mostrar tots els camps de la consulta.

Canvia els noms dels camps, posant les etiquetes

• Nom

• Familia

• Data 

• Nombre

• Lloc

Anomena l'informe report_birds_count_2.

d) Modifica el títol de l'informe a Informe ànecs i merles.

Insereix el teu nom en la capçalera de l'informe.
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 1.1.4.15 Carta de formulari

Un dels grans avantatges del paquet LiberOffice, és la interacció que possibilita entre 

les seves aplicacions.

En aquest apartat veurem com interactuen Calc, Base i Writer.

L'objectiu és crear una carta model per avisar els responsables dels alumnes d'una 

classe, que les seves filles i fils participaran en una excursió.

En primer lloc obrirem el document Calc alumnes.ods, en el qual es troba un listta 

d'alumnes i alumnes. 

Aquest llistat l'hem de convertir en la taula d'una bases de dades que anomenarem 

alumnes.odb.

Comencem creant la base de dades amb l'assistent, assegurant-nos de seleccionar el 

registre (1), ja que és necessari per poder accedir-hi des de Writer. 
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Creada alumnes.odb, hem de crear la taula alumnes. Això ho farem copiant i 

enganxant el llistat del document Calc alumnes.ods.

 Creada la taula alumnes a alumnes.odb, comencem a redactar l'avís d'excursió amb 

Writer, basant-nos en el següent model. Desarem el document amb el nom 

avis_excursio.odt.

 

Paulino Posada Blog pàg. 115 de 124 

http://tic-tac-2015.blogspot.com.es/


TIC  09/18

Redactat l'avís hem de enllaçar els camps variables amb els camps de la taula 

alumnes. Per això, obrim el document de text avis_excursio.odt i   menú View, 

seleccionem Data sources.

Ara podem pitjar damun camp de la taula i arrastar-lo a la posició del document 

Writer on ha de quedar inserit.
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Per comprovar el resultat de la inserció de dades sleccionem File > Print 

Apareix la finestra que demana confirmació de que volem crear una carta formulari.

Tras confirmar, apareix la següent finestra Combinació de correu, on seleccionarem 

l'opció de sortida a arxiu. 

Finalment haurem d'anomenar i desar el document. Obrint-lo, podem comprovar que 

les dades de la taula alumnes s'han inserit correctament en els camps del document 

avis_excursio.odt.

Desa el document com a PDF 

File > Export as PDF
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 1.1.4.16 Documentació Base i enllaços d'interès

Tutorial   Base en castellà.

Tutorial Base en anglès.

Base tutorials

http://www.pitt.edu/~poole/libreofficeframe.htm

Field types

http://plan-b-for-openoffice.org/glossary/term/field-types

Modificar controls de formulari

https://help.libreoffice.org/Common/Form_Controls#Modifying_a_Control
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http://blogtecnos.blogspot.com.es/2012/01/hoja-de-caculo-libreoffice-calc.html

http://ticenelbachilleratodeadultos.blogspot.com.es/p/writer-como-se-hace.html

https://ticenbachilleratosagra.wordpress.com/

Trabajo final procesadores de texto

Vamos a realizar un ejercicio completo de procesadores de textos. Deberéis tener en 

cuenta las siguientes consideraciones:

• Se deberá utilizar obligatoriamente estilos para la realización del documento 

(estilos de carácter, párrafo, página,…) 

• Las páginas tendrán formato A5 

• La primera página del trabajo será diferente al resto y contendrá únicamente el 

título, nombre del/de los autor/es y el curso. Los márgenes serán de 2cm 

• El resto de páginas tendrán como formato 

• Margen superior, derecho e inferior de 1cm 

• Margen izquierdo de 1,5cm (para reservar para encuadernación). 

• En el encabezado aparecerá a la izquierda los nombres de los autores y a 

la derecha el curso. Deberá poseer una línea horizontal para separar 

encabezado y texto. 

• En el pie de página deberá aparecer el texto “pagina X de Y” donde X es 

el número de página actual e Y es el total de páginas. También poseerá 

una línea horizontal divisoria. 

• En la segunda página deberá aparecer un índice de contenido generado 

automáticamente por el ordenador 

• Cada ejercicio que se indica deberá aparecer en una página diferente con salt 
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de página manual.

Los títulos de los apartados deberán tener el siguiente formato: 

• Párrafo sombreado y con línea inferior 

• Fuente times new roman, tamaño 160%, negrita y cursiva. Con efecto de 

relieve saliente. Se debe ver el texto blanco. 

• Los subtítulos de los apartados deberán tener el siguiente formato: 

• Párrafo con línea inferior, pero no sombreado. 

• Fuente times new roman, tamaño 14pt, negrita y cursiva. Color de la 

fuente gris al 40% y efecto de sombra. 

• Los ejercicios tendrán que hacerse lo más parecidos posible al modelo que os 

dejo a continuación. Además se deberán realizar con las técnicas indicadas en 

los títulos y subtítulos 

• Las imágenes que necesitáis las podéis encontrar en la web del IES La Sagra, 

en el siguiente apoartado. 

Deberéis de seguir exactamente las indicaciones dadas anteriormente

El modelo y los ejercicios los tenéis pinchando aquí.

Al final generaréis tres documentos que deberéis guardar para enviármelos 

por edmodo:

1. Documento final del ejercicio (gXX-final-writer.odt) 

2. Documento en pdf final del ejercicio (gXX-final-writer.pdf) 

3. Plantilla solamente con los estilos de las páginas, títulos, párrafos,… (gXX-

plantilla-writer.ott) 
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Europa Amèrica Àfrica Àsia Oceania

Homes
Dones

Homes
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522
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1500
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320
330

POBLACIO MUNDIAL (en milions d'habitants)
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